App - Script

Cette série d’épreuve vous confronte aux vulnérabilités liées à des faiblesses d’environnement, de configuration ou encore à des erreurs de développement dans des langages de script ou de programmation.

Les identifiants de connexion sont fournis pour les différents challenges, le but du jeu est d’obtenir des droits supplémentaires en exploitant des faiblesses de l’environnement (permissions incorrectes sur les fichiers, protection par chiffrement faible, etc.) et des erreurs de développement pour obtenir un mot de passe permettant de valider chaque épreuve sur le portail.

Prérequis :
- Maitriser l’environnement shell UNIX, les langages de programmation python et perl ;
- Maitriser les outils de manipulation de fichiers binaires ;
- Connaitre le langage C.

Résultats des challenges Résultats des challenges

Pseudonyme Epreuve Langue Date
Magych   Bash - System 1 en 19 décembre 2018 à 01:51
f1ndm3   Bash - System 1 en 19 décembre 2018 à 00:26
grimmware   Perl - Command injection en 18 décembre 2018 à 23:21
Tipa   sudo - faiblesse de configuration fr 18 décembre 2018 à 23:13
brexit   Bash - System 2 fr 18 décembre 2018 à 23:05
rorre13   Python - input() de 18 décembre 2018 à 23:00
grimmware   Bash - System 2 en 18 décembre 2018 à 22:59
brexit   Bash - System 1 fr 18 décembre 2018 à 22:56
neatzsche   Python - pickle en 18 décembre 2018 à 22:55
grimmware   sudo - weak configuration en 18 décembre 2018 à 22:52